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EXCEL 98 TUTORIAL
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© Andy Eng, Columbia University 1998

Note for Excel 97 users:  All features of Excel 98 for Macintosh are available in Excel 97 for Windows,
with a few differences. Instead of the Apple command key (    ) the ctrl  key is used for keyboard
shortcuts. Instead of the return  key, the enter  key is used. In addition, there are contextual menus that
can be accessed by clicking the right mouse button. This menu brings up a list of functions that relate to
the area that the mouse cursor is over.

I. What is Excel?
II.  Basic Excel definitions / features
III.  Graphing
IV.  Formulas and Functions

I. What is Excel?
Microsoft Excel is a spreadsheet program, a table of rows and columns where data can be
entered. Data can be of many types, numeric, strings, or alphanumeric. Data can be manipulated
and analyzed in Excel, quickly and efficiently. Part of the analytic arsenal of Excel is database,
statistical, graphical, and other mathematical functions.

II. Basic Excel definitions / features
When you open Excel, a blank Excel sheet opens. On top are the various menu bars.

Below the menu is the sheet. It is divided up into referenced columns and rows. One column is
one vertical section of a sheet. Columns are indexed by capital letters, as seen on the top of the
sheet. One row is a horizontal section of a sheet. Rows are indexed by numbers, as seen on the
left-hand side of the sheet.

The intersection of a column and row is defined as a cell. Cells are where one inputs
data, usually one data value per cell. Valid data inputs can consist of characters, strings,
numbers, dates, currency, or formulas. (Formulas will be discussed later.) A column letter and a
row number reference one cell. For example, the first cell found at the intersection of the first
column, denoted A, and the first row, 1, is referenced as A1. When referencing cells, it does not
matter whether the letter is capitalized, i.e. cell a1 is the same as cell A1. When referencing a
block of cells (or range of cells), colons separate the beginning and the end cells for the range.
For example, A3:A10 refers to the column of each cell from A3 to A10. B3:D6 refers to the
block of cells which starts at B3 as the upper left-hand cell and ends with D6 as the lower right-
hand cell.

Inputting / Editing cells
Navigating around the cells can be done with the arrow keys, unless a cell is in edit mode. In edit
mode, data can be entered, and it can be distinguished from other modes because a blinking
cursor can be seen.

After data is entered, pressing the Return key enters the data into one cell, and moves the
highlighted cell down 1 row. To edit a cell that already contains data, double-click on the cell, or
select the cell and press the F2 key.



Created on 09/02/98 11:58 PM 2

The mouse is very important in Excel, as it is used to select a cell or range of cells. One click
over a cell highlights it, while double-clicking allows editing of the cell. One click on a row or
column index selects the whole row or column, respectively. If one holds down the mouse button
and drags the mouse, a whole range of cells, rows, or columns can be selected.

Be wary of the cursor as it moves across the screen. While over the sheet, the cursor changes
from an arrow to a crosshair. While over a line separating the column or row indices, the cursor
changes to a line with 2 perpendicular arrows. Holding the mouse button while the cursor is in
this form will change the column or row spacing and not select columns or rows.

Example 1
Try entering some data values into the sheet. Input x into cell A1, y into cell B1. Cells A1 and
B1 will serve as axis labels in a graph for a later example. Fill cells A2:A6 with the values 1, 2,
3, 4 ,and 5 with one number per cell. Fill cells B2:B6 with the values 2, 4, 6, 8, and 10, with one
number per cell.

Excel has some features that allow for manipulation of data around the sheet. These features
include clear, copy, cut, paste, insert column/row, delete column/sheet, redo, and undo. All
these functions can be accessed under the Edit menu, with the exception of insert functions,
which can be accessed under the Insert menu. Most functions also have keyboard shortcuts, a
combination of keystrokes that accomplishes the same task. Shortcuts allow for more efficient
data manipulation. Shortcuts are included, where applicable, after the function name below:

• Clear contents (command–B): The clear menu has many options, but the one of
interest is clear content, which clears the contents of the selected cells.

• Copy (command–C): The copy command copies the selected cells.
• Cut (command–X): The cut command copies the selected cells, and clears the

contents of the cells at the same time. The cut command is used to move data.
• Paste (command–V): The paste command pastes copied or cut cells into the selected

region. Be sure that the area you select as the target of the paste contains the same
number of columns and rows as the original copied area. There are a couple of neat
tricks that can be done with paste that will be explained later.

• Insert:  The insert menu has the option to insert a column or row. When inserting
either, it inserts a column or row before the selected area. If you select a column C,
the new column appears to the left. If you are selecting a row 4, the new row appears
above. You can insert multiple columns or rows by selecting an appropriate number
of columns or rows before insertion. The new columns or rows also appear before the
selected area.

• Delete: When deleting columns or rows, the column or row must be selected in
entirety by clicking on the respective index. Unlike clear, delete removes the entire
row or column.

• Redo (command–Y): Redo repeats the previous step or undoes the last undo.
• Undo(command–Z): Undo erases mistakes by removing the last changes on the

sheet.
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Example 2
Using the previous example, select the range of cells A1:B6. Go to the Edit menu, and select
Clear and then Contents to clear content. Press command–Z to undo. Press command–C to
copy the contents. Select the range C7:D12 and press command–V. A duplicate of the cells are
seen. Select column B and under the Insert menu, select the Columns option. A new blank
column B is there and the column of y values previously labeled B, is now labeled C. Select
column B and under the Edit menu, select Delete. Select row 3 and under the Insert menu, select
the Rows option. A new blank row 3 appears, and the column that was row 3 is now row 4.
Select range A4:B7 and press command–X. Select A3:B6 and paste by pressing command–V.

Now try out other things.

Within one Excel file, one can have multiple sheets. When Excel opens, there are several blank
sheets that are open. Tabs at the bottom differentiate them as Sheet1, Sheet2, and Sheet3, by
default.

File / Print functions
Under the File menu, there are several items of interest:

• New (command–N): Creates a new spreadsheet file.
• Open (command–O): Opens an Excel file.
• Save (command–S): Saves an Excel file, in Excel 98 format. There are two

additional save features in Excel 98, Save As… and Save as HTML…. Save As…
allows one to save an Excel file in another format, such as an earlier version of Excel,
or as a plain text file. Save as HTML… allows one to save an Excel file as an HTML
table readable web browsers.

Note: Formatting may be lost upon conversion to other formats, including HTML. Also note that
Excel 97 and Excel 98 can read the same files without loss of formatting.
• Print Preview: Before printing your file, this function allows one to preview the

printed file, to see it exactly as it will be printed. This is an important function
because it allows one to check for proper pagination of the spreadsheet.

• Print ( command–P): Sends the selected print area to the printer. This will print all
sheets in one file.

Example 3
Save your file to a floppy disk. Press command–S and save the file as lines.

Note: If you desire to use your disk in both Macintosh and Windows computers, save the file as
lines.xls.

III. Graphing
Creating XY (scatter) graphs
1. From the Insert menu, select Chart. You should now see a chart wizard.
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2. Under the Standard Types tab, select XY (Scatter). From Chart Sub-Type, select either
unconnected points (top) or points connected with straight (not smooth) lines (bottom left.)
Press Next.

3. Under the Data Range tab, in the Data Range: field, click on the button to the right. Select
all your data points to be included in the graph, including any axis labels. Under the Series
tab, (if the data is not  preselected for you) select the name of your y axis under Name. Do
this by clicking on the button to the right of the name field, then click on the cell. Do the
same for your X and Y values. Use the Add and Remove buttons to add or remove additional
data series, or sets of y-axis data points. This allows one to plot multiple series that use the
same x-axis. Press Next.

4. Add a chart title and axis titles, then press Finish.
5. Clicking on different areas of the graph highlight different components. The format of

different components can be changed by selecting the first menu item under the Format
menu. For example, highlight the data series by clicking on one of the data points. The first
item under the Format menu is Selected Data Series, which brings up a menu appropriate for
the data series.

6. Clicking on the chart also changes the menu item Data into Chart. The menu items under
Chart open the same menus seen in the chart wizard. In addition, there is the option to Add
Trendline, which allows one to calculate a linear or exponential fit.

Example 4
Using the data from the previous exercises, and the graphing instructions, construct a line graph
using the column A as the x-axis data and column B as the y-axis data. Use row 1 as the axis
labels.

Note when you place the mouse over a point in the graph, the coordinates of the point appear in a
box over the point after a second. Using the graph from Example 4, the point (1,2) would show
up in a small pop-up label when the cursor is over the first point.

To change the set of x or y values, either to remove or extend them, use the Source
Data… option under the Chart menu. Under the Series tab, X and Y values can be modified.

Advanced functions (optional)
Linear fit of graphs

To add a best-fit line, click a point on the graph to highlight all of them. From the
menu, select Chart, then Add Trendline. Select Linear as your Type, then select the
Options tab. In here, select Display Equation on Chart. Press OK. Now you should
see a best-fit line, along with the equation.

IV. Formulas and Functions
Formulas
Formulas, specifically numeric formulas, are algebraic expressions consisting of numbers, cell
references, mathematical symbols (+, -,* , /, %) and functions. For example, a formula for a
straight line could be 2*x – 2, where x is a cell reference like A4, resulting in the formula, 2*A4
– 2. Inputting formulas into Excel is the same as inputting cells, except an equal sign (=)
precedes the formula. Inputting the formula 2*A4 – 2 will result in the string “2*A4 – 2” rather
than the intended result =2*A4 – 2, which causes Excel to calculate the formula using the
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variable number located in the cell A4. When inputting formulas, it is important to remember the
precedence of operations. Parentheses become extremely important!

Functions are similar to formulas, but compute a value that a normal algebraic expression cannot
express, or express easily, such as the natural logarithm of  a number. Functions are used in
formulas just like another term. To compute 10 times the natural log of 6.03, the natural log
function LN(x) is used, where x is a number or cell reference. The complete formula is
=10*LN(6.03). The terms inside the parenthesis are function arguments, and can be numbers,
strings, or cell ranges, depending on the function.

SOME MATHEMATICAL EXCEL FUNCTIONS
EXP(x) LN(x) POWER(x,y) LOG10(x)
Calculates ex Calculates ln (x) Calculates xy Calculates log (x)

PI() SQRT(x) SUM(a1, a2, a3, a4...) or SUM(az, a y)
Calculates π Calculates square root of x Calculates sum over cell range, like A3:A7

REMINDER : All formulas entered must be preceded by an equal sign =

Filling Data Ranges
Many times in Excel, duplicate data has to be copied into other cells. Other times, a column must
be filled with data of fixed intervals. These two actions can be done using the Fill option located
under the Edit menu. Click and hold down the mouse button on the cell containing the value to
be copied, and select the cells that will contain the duplicate data. After blocking out the area, go
to the Edit menu, select Fill, and then the appropriate fill direction, which starts from the first cell
selected. If you want to fill across two directions, like down and then right, the Fill  option must
be used again, but in the other direction.

You can also use copy and paste to duplicate data. Copy one cell value, then select any number
of cells to copy to (it need not be contiguous with the original data), and then paste.

To fill a data series using an initial value and a constant interval, select the cell with the initial
value. Go to the Edit menu, select Fill , and then Series.... Under Series in, select Columns. Input
a Step value and the Stop value. Press OK.

Copying and Pasting Formulas
When copying and pasting formulas, keep in mind that cell references are relative. This is useful
for entering formulas. The y values in table 1, shown below, are obtained by using the formula
x2. To do this, the entry for cell B2 is =A2*A2 .

Copy cell B2 and paste it into cells B3 through B6. Note that the values in column B do
correspond to x2 (i.e., B3 is A3*A3, etc.) Keep this relative cell references in mind when pasting
formulas.

A B C
1 x y formula
2 1 1 A2*A2
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3 2
4 3
5 4
6 5

Table 1

A B C
1 x y formula
2 1 1 A2*A2
3 2 4 A3*A3
4 3 9 A4*A4
5 4 16 A5*A5
6 5 25 A6*A6

Table 2

Example 5
Using the data from the previous exercises, start to fill the rest of column A, in intervals of 1, to
100. Leaving the column label in B1, clear the data from column B. Type in cell B2, =2*A2+2.
Copy this formula into cells B3:B101. Extend the graph to include these new x and y points.

Pick 2 points at random from the graph and calculate the slope. Does it match the formula?

Defining names for absolute cell reference
There are situations where cell references in formulas must be absolute, and not relative,

so that cells references are constant upon pasting. This is done by defining a name for a
particular cell. Defining names allows one to refer to the contents of a cell as a constant, and
names can be used in place of cell references. Alternatively, one can use named cells as variables
whereby changing its value can affect all cells that contain formulas with the variable. Let’s give
the  cell C1 a value of 8.314. Select the cell and from the Insert menu, go to Name and Define….
Under Names in workbook: type in the name for the cell, for example gasconst. Now a
reference can be made to cell in any formula by typing the name out, like 1.5*gasconst*A3.
Upon copying this cell, the cell reference to column A changes relatively, but the gasconst term
does not change even if the cell position changes.

Getting help
With Excel 98, there is a help system, which can be accessed by pressing the F1 key or selecting
Microsoft Excel Help under the Help menu. By typing in a question or term, you get information
on the term or instructions on how to implement a function.


